Report generation not working with Grafana instance running with https

 Hi everyone,

I am a new user of Skedler and I have encountered some issues regarding the generation of pdf with Grafana.

My Grafana instance has been set up to run with https.

When I try to generate a report or preview it I get this error on the Skedler interface :

Error in generatingMY REPORTreport. Check the Grafana configurations - 04/11/19 3:19PM

And something like this appears in the logs :

Dashboard ReportEngine - Error in generating report, check whether grafana is running  Error: net::ERR_CERT_AUTHORITY_INVALID at https:///

at navigate (/opt/skedler/node_modules/puppeteer-core/lib/FrameManager.js:107:37)

 at <anonymous>

at process._tickCallback (internal/process/next_tick.js:188:7)
  -- ASYNC --

at Frame.<anonymous> (/opt/skedler/node_modules/puppeteer-core/lib/helper.js:144:27)

at Page.goto (/opt/skedler/node_modules/puppeteer-core/lib/Page.js:624:49)

at Page.<anonymous> (/opt/skedler/node_modules/puppeteer-core/lib/helper.js:145:23)

at Object.openDashboard (/opt/skedler/server/reportEngine/puppeteer/grafanaEngine.js:1:2250)

at open (/opt/skedler/server/reportEngine/puppeteer/reportEngine.js:1:6487)

at /opt/skedler/server/reportEngine/puppeteer/reportEngine.js:1:12428

at <anonymous>

at process._tickCallback (internal/process/next_tick.js:188:7)

If I hook up Skedler to a Grafana instance not running behind https (so http), it works perfectly.

The platform on which skedler is installed has been configured to trust the certificate used by Grafana.

Environment :

Ubuntu v18.04.2

architecture -> amd64

Skedler 3.12.1

Please let me know if anyone you has a solution for this.

Notes :

 - The configuration file has been submitted for your review

- The domain name has been changed for confidentiality issues.

(6.46 KB)


# The host to bind the skedler server to.

host: ""

this entrance must be similar on /etc/hosts

Hi Rui,

Thanks for your feedback.

One thing I forgot to mention is the fact that I am using skedler docker container.

I tried to put on the line you cited, I tried any IP in /etc/hosts, I also tried the IP address of the server running Grafana, but it didn't work.

Do you have any other leads ?

Login or Signup to post a comment